Problem uploading image

This area is for the discussion of what's new, what's on your mind, and general photographic topics. A place to meet, make comments on this site, and get the latest community news.

Moderators: ChrisR, Chris S., Pau, rjlittlefield

stephenlewis
Posts: 7
Joined: Sat Oct 21, 2017 3:49 pm
Location: Cheshire. GB.
Contact:

Problem uploading image

Post by stephenlewis »

Hello there

I'm having a problem uploading an image. When I press the button I get the message 'The datatype application/octet-stream is not supported.' I'm using an Apple Mac and Safari. Any help would be appreciated. Thanks.

rjlittlefield
Site Admin
Posts: 20860
Joined: Tue Aug 01, 2006 8:34 am
Location: Richland, Washington State, USA
Contact:

Post by rjlittlefield »

That sounds like what happens when a browser has no idea what the actual file type is. Does your file name end with ".jpg" ? If not, then try changing its name and repeating the upload.

I would be interested to know how your image was generated. On my Mac, even if I rename a file so that it does not have a recognizable extension, Safari somehow figures out what the file type is. I assume it gets that either from some invisible metadata maintained by Mac OS or from interpreting the file contents. Either way, something about your file and/or file name is preventing it from being recognized as an image.

--Rik

stephenlewis
Posts: 7
Joined: Sat Oct 21, 2017 3:49 pm
Location: Cheshire. GB.
Contact:

Post by stephenlewis »

rjlittlefield wrote:That sounds like what happens when a browser has no idea what the actual file type is. Does your file name end with ".jpg" ? If not, then try changing its name and repeating the upload.

I would be interested to know how your image was generated. On my Mac, even if I rename a file so that it does not have a recognizable extension, Safari somehow figures out what the file type is. I assume it gets that either from some invisible metadata maintained by Mac OS or from interpreting the file contents. Either way, something about your file and/or file name is preventing it from being recognized as an image.

--Rik
Thanks Rik. The software hadn't put an extension on the file name. It's worked fine now.

Post Reply Previous topicNext topic