www.photomacrography.net :: View topic - Manual flash directly from LiveView with EOS 500D
www.photomacrography.net Forum Index
An online community dedicated to the practices of photomacrography, close-up and macro photography, and photomicrography.
Photomacrography Front Page Amateurmicrography Front Page
Old Forums/Galleries
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 
Manual flash directly from LiveView with EOS 500D

 
Post new topic   Reply to topic    www.photomacrography.net Forum Index -> Macro and Micro Technique and Technical Discussions
View previous topic :: View next topic  
Author Message
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sat Mar 31, 2018 4:33 pm    Post subject: Manual flash directly from LiveView with EOS 500D Reply with quote

Hi,

This is a set-up to use a manual flash unit on a microscope and fire the flash while the camera is in LiveView.

It would be useful to be able to use flash on a microscope directly from LiveView (EFSC) for very fastidious subjects like ciliates which may be disturbed even by first curtain shutter movements of the camera.

The Canon EOS 500D disables EFSC whenever a flash is physically connected to the camera hotshoe. Whenever a flash is connected, the camera goes through a full shutter + mirror movement BEFORE the exposure. More expensive EOS models allow the mirror to be disabled but the shutter movement still occurs.

The solution would be to release the camera and fire the flash independently of each other. However, the delay between pressing the shutter and the start of the exposure varies greatly; is too irregular to synchronise this with firing the flash reliably. Rik described the problem in detail in on older post: http://www.photomacrography.net/forum/viewtopic.php?t=13726 In his measurements, the trigger delay was between 70 and 500 ms.

I looked into this myself and encountered the same problem. I have now found a partial work-around.

This allows:

- exposure times down to 1/200 s, short enough to allow simultaneous continuous LED illumination that is bright enough for observer use on a 80:20 trinocular head
- firing the flash with EFSC enabled
- countinuous LiveView through EOS Utility Remote shooting
- intermittent shooting without flash use is possible through EOS Utility
- works at least 80 % of the time

The crucial observation was that the 500D, after a manual trigger, generates a voltage signal at the electrical shutter cable socket (2.5 mm jack) reliably around 70 ms before the exposure begins.

I have no idea why the camera generates the voltage signal but I found that the Cactus V6 transceiver interpretes this as a trigger signal and can in turn be used to fire a flash remotely.

You need two Cactus V6 for this; one is connected through a cable to the EOS 500D. It receives the voltage signal from the camera. It in turn send a wireless signal to a second Cactus V6 which has a DELAY timer function. The correct delay time has to be found for each unit (I have a unit with a delay time at 58 ms (more recent V6) and another with 68 ms (older version of V6)).

The camera flash is mounted to the hotshoe of the second Cactus V6 unit. I use a Yongnuo YN-560 III speedlite manually set to 1/128 power. The power setting remains largely unchanged; exposure is controlled though ND filters, through adjusting the camera ISO and though digital image processing.


Parts needed:

- Mechanical shutter release cable (seriously!) - for now this works only if the camera is triggered mechanically, it doesn't work though EOS Utility Remote shooting
- Shutter release cable adapter (strap or bracket) as the EOS 500D doesn't normally accept a mechanical shutter release cable
- 2.5 mm to 3.5 mm jack cable (for audio use)
- two Cactus V6 transceivers (I have not tested the V6 II)
- manual flash unit
- USB-mini USB cable to connect 500D to computer

I tested the Yongnuo YN-560 III and decided to convert to for use on a microscope. The set-up also works with the Cactus RV60 flash unit (it has an inbuilt transceiver so you need only one additional V6 unit) but this was tested off the microscope.

The 500D has to be in LiveView and there should be no electrical connection to a camera lens (either use an analogue camera lens or tape off the contacts!).

When setting this up, there is usually some difficulty in getting the camera to accept mechanical triggers while it is also connected to EOS Utility at the same time. I always have to turn the camera off and on and pull cables and reconnect before it finally starts working. I haven't figured out why this is, yet. Once the camera accepts the mechnial triggers, it does so for the remainder of the session.

Even then, the flash frequently misfires (see below). I would describe it as "temperamental" but I figured I'll show it here and maybe get imput for further improvements.

Regards, Ichty


Figure 1: Parts needed

Copyright: ©Canon ©Cactus CC: Xeviro https://commons.wikimedia.org/wiki/File:OldCamera_CableRelease.jpg

Figure 2: Settings used

©Canon ©Cactus CC: Xeviro https://commons.wikimedia.org/wiki/File:OldCamera_CableRelease.jpg
Back to top
View user's profile Send private message
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sat Mar 31, 2018 4:44 pm    Post subject: Reply with quote

Now for some tests of the reliability of the set-up.

In the first test, I first did a normal exposure (1/4 s) at a low LED illumination setting. Then an exposure at 1/200 s to demonstrate that the background illumination is very dim at 1/200 s. Then I started using the mechanical trigger. The first expose is almost always a misfire. The following exposures were made using the flash at 1/128 power and the camera at 1/200 s shutter speed. In the middle of the test series, I did one exposure at 1/5 s using EOS Utility, after that I went back to using flash.

Success rate was 84 %.

The second test was at 1/100 s shutter speed. The success rate was slightly higher.

The third test was more like a real life test. Shutter speed 1/160 s and the pictures of pond life were taken over approx. 30 min. Success rate again around 80 %.

Test 1:


Tests 2 and 3:
Back to top
View user's profile Send private message
mawyatt



Joined: 22 Aug 2013
Posts: 1552
Location: Clearwater

PostPosted: Sat Mar 31, 2018 4:49 pm    Post subject: Reply with quote

This might help.

https://www.photomacrography.net/forum/viewtopic.php?t=36356&postdays=0&postorder=asc&start=0

Best,
_________________
Research is like a treasure hunt, you don't know where to look or what you'll find!
~Mike
Back to top
View user's profile Send private message
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sat Mar 31, 2018 4:54 pm    Post subject: Reply with quote

With regards to the Cactus V6 units: They were recommended to me because of the Delay timer function. Other remote flash units may have this function as well but V6 are certainly useful gadets. They are expensive new but used units can be purchased from $25.

If you are good at setting up your own electronic devices, you could probably use one of the programmable delay times switch units on Ebay (around $5) and get it to interprete the voltage signal from the camera as a trigger for the flash unit and even use it to temporarily dim the microscope illumination!

I would also be interested in people testing their own EOS cameras for that mysterious voltage signal (function unknown) using a voltmeter. It is probably present in other EOS models as well.
Back to top
View user's profile Send private message
rjlittlefield
Site Admin


Joined: 01 Aug 2006
Posts: 19184
Location: Richland, Washington State, USA

PostPosted: Sat Mar 31, 2018 5:47 pm    Post subject: Reply with quote

This is very interesting, but I am totally confused.

As I write this, I am looking alternately between my physical camera, the manual for it, and your diagrams, and I simply cannot make things match up.

Where you show a mechanical shutter release plugging in, I have a solid clear thing that the manual describes as a "Red-eye reduction / Self-timer lamp", and where you show a 2.5 mm socket to plug in a cable, I have a small black pushbutton that triggers the built-in flash. The manual clearly says "Rebel T1i and EOS 500D" on the cover, and the camera says "Rebel T1i".

Please look again -- what type camera are you working with???

--Rik
Back to top
View user's profile Send private message Visit poster's website
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sat Mar 31, 2018 6:03 pm    Post subject: Reply with quote

Hi Rik,

It's the 500D. Sorry for the confusion. The locations in the figure above are just symbolic (don't follow the black lines, they are left over from the original Canon drawing). The correct locations are shown below:

a) For the trigger cable: "Shutter button"
b) 2.5 mm jack: "Remote control terminal"

The mechanical trigger cable doesn't plug into anything; the Canon doesn't accept a mechanical trigger cable. Instead you have to use either a bracket mounted to the tripod thread: https://www.flickr.com/photos/danilokrahl/8560122908 or a "50 shades-style" camera release strap. Personally, I use a Kaiser 6154 strap http://keyphoto.com/Kaiser-6154 although I'm not 100 % happy with it. You could also trigger the camera by hand using the "shutter button", it's just impractical.

Regards, Ichty




© Canon
Back to top
View user's profile Send private message
rjlittlefield
Site Admin


Joined: 01 Aug 2006
Posts: 19184
Location: Richland, Washington State, USA

PostPosted: Sat Mar 31, 2018 6:11 pm    Post subject: Reply with quote

Aha! Don't follow the black lines.

I had not realized that I was following the black lines, but of course that's exactly what I was doing.

OK, so now I think what you're telling me is that if I push the physical shutter release button, I should see a signal outgoing on what is normally the remote shutter release input socket. Is that correct?

--Rik
Back to top
View user's profile Send private message Visit poster's website
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sat Mar 31, 2018 6:16 pm    Post subject: Reply with quote

rjlittlefield wrote:
OK, so now I think what you're telling me is that if I push the physical shutter release button, I should see a signal outgoing on what is normally the remote shutter release input socket. Is that correct?


That's right.
Back to top
View user's profile Send private message
rjlittlefield
Site Admin


Joined: 01 Aug 2006
Posts: 19184
Location: Richland, Washington State, USA

PostPosted: Sat Mar 31, 2018 11:17 pm    Post subject: Re: Manual flash directly from LiveView with EOS 500D Reply with quote

Ichthyophthirius wrote:
The crucial observation was that the 500D, after a manual trigger, generates a voltage signal at the electrical shutter cable socket (2.5 mm jack) reliably around 70 ms before the exposure begins.

I confirm that my T1i works the same way.

What I did was to take the back off an RS60-E3 remote control so that I could easily access the contacts.

Then I connected three instruments to the common and full-press contacts: a Fluke 29 voltmeter, a PicoScope 2205A digital scope to catch the transitions, and a Tektronix 465B analog scope to provide a bright trace to be photographed.

The camera was set up in Live View mode with a Canon 100mm macro lens, electronic connections with auto diaphragm. Exposures were triggered by pressing the camera's shutter release button by hand.

So, the data flow is that physical button press causes the signal transition with some unknown delay, the signal transition starts the analog trace, separately something triggers the exposure, which catches the dim portion of the analog trace that is in afterglow, plus the bright portion of the analog trace that is stroked out while the exposure is being done. Delay from signal transition to actual exposure is indicated by the time from start of analog trace to the start of the bright portion of the trace, following the strategy at http://www.photomacrography.net/forum/viewtopic.php?t=13726 .

According to the Fluke voltmeter, the signal measured as 3.014-3.020 VDC while the physical shutter button was not pressed, and 0.000 VDC while the button WAS pressed. On a human time scale, the signal simply tracks the shutter button: pressed/notpressed = 3V/0V. The transitions were debounced and damped, taking about 0.5 microseconds to fall from 3V to 1V. (In contrast, pressing the button on the RS60-E3 to short the contacts produced a much quicker transition with quite a bit of overshoot and ringing.)

In my tests, the exposure began 66-68 ms after the signal fell, although I did see one case in about 100 test exposures where the exposure was delayed to about 72 ms after the signal fell.

Treating this as 6 ms variation in 100 tests, this signal appears to be several times more stable than the 16 ms variation that I saw when triggering from the light on the back of the camera (HERE).

Triggering from this unexpected output seems like a good approach when physical shutter press is acceptable.

--Rik
Back to top
View user's profile Send private message Visit poster's website
Ichthyophthirius



Joined: 07 Mar 2013
Posts: 801

PostPosted: Sun Apr 01, 2018 4:30 am    Post subject: Reply with quote

Hi Rik,

Thank you very much for taking the measurements!

A friend of mine found a similar voltage drop on the 5D II but he didn't take delay measurements. This is very encouraging.

-------------------------------------------

I'm very interested if this holds up for other cameras (especially the 7D II which I think I will eventually adopt for use on my microscope). If anyone here has the means for testing, please let us know!

Regards, Ichty
Back to top
View user's profile Send private message
ChrisR
Site Admin


Joined: 14 Mar 2009
Posts: 7790
Location: Near London, UK

PostPosted: Sun Apr 01, 2018 12:01 pm    Post subject: Reply with quote

A thought: If the wired trigger is used with a short enough pulse ( perhaps a couple of ms) which then goes open circuit, is there the same "output" on the connector?


?
_________________
Chris R
Back to top
View user's profile Send private message
TheLostVertex



Joined: 22 Sep 2011
Posts: 295
Location: Florida

PostPosted: Mon May 07, 2018 2:24 pm    Post subject: Re: Manual flash directly from LiveView with EOS 500D Reply with quote

Ichthyophthirius wrote:
Hi,
However, the delay between pressing the shutter and the start of the exposure varies greatly; is too irregular to synchronise this with firing the flash reliably. Rik described the problem in detail in on older post: http://www.photomacrography.net/forum/viewtopic.php?t=13726 In his measurements, the trigger delay was between 70 and 500 ms.


I posted my thoughts on this another thread as well, from when I was testing with my focus stacking software http://www.photomacrography.net/forum/viewtopic.php?p=186522 To sum up, I believe that the shutter triggering process is reliable, but there is a process loop that occasionally checks the shutter for a signal. If the signal pulse happens right before the camera checks the port then it happens quickly, but if the signal happens after the camera has checked, it needs to wait for the camera to loop back and check it again(a few hundred milliseconds later). Just my theory based on testing different shutter pulse lengths.


Ichthyophthirius wrote:

The crucial observation was that the 500D, after a manual trigger, generates a voltage signal at the electrical shutter cable socket (2.5 mm jack) reliably around 70 ms before the exposure begins.

I have no idea why the camera generates the voltage signal but I found that the Cactus V6 transceiver interpretes this as a trigger signal and can in turn be used to fire a flash remotely.


This makes sense. The remote trigger is an open circuit and is triggered simply by shorting the connection(for either the full press or half press). So I can see all the shutter signals running though the same paths. Neat find!


rjlittlefield wrote:
Triggering from this unexpected output seems like a good approach when physical shutter press is acceptable.


Physical shutter not needed as the first post states, it can be triggered via USB. I am going to wager that it other canon cameras could be triggered via wifi with the same results as well. Since you can trigger via usb at the very least, everything can be automated easily.

Edit:
ChrisR wrote:
A thought: If the wired trigger is used with a short enough pulse ( perhaps a couple of ms) which then goes open circuit, is there the same "output" on the connector?


The remote trigger is always open, until it is closed by what ever you hook up to it.
_________________
-Steven
Flickr Macro Rig Control Software
Back to top
View user's profile Send private message
mawyatt



Joined: 22 Aug 2013
Posts: 1552
Location: Clearwater

PostPosted: Mon May 07, 2018 3:24 pm    Post subject: Re: Manual flash directly from LiveView with EOS 500D Reply with quote

TheLostVertex wrote:


I posted my thoughts on this another thread as well, from when I was testing with my focus stacking software http://www.photomacrography.net/forum/viewtopic.php?p=186522 To sum up, I believe that the shutter triggering process is reliable, but there is a process loop that occasionally checks the shutter for a signal. If the signal pulse happens right before the camera checks the port then it happens quickly, but if the signal happens after the camera has checked, it needs to wait for the camera to loop back and check it again(a few hundred milliseconds later). Just my theory based on testing different shutter pulse lengths.


Steven,

This might be what's happening, but it seems the camera CPU should be on an interrupt driven trigger rather than in a long slow software checking loop. With an interrupt driven routine you would think a few microseconds delay variation, not the many milliseconds delay.

I've experienced the same long uncertain delays with the Nikon D850 which is noted here in a solution for use with a external flash/strobe.

https://www.photomacrography.net/forum/viewtopic.php?t=36356&postdays=0&postorder=asc&start=0

Anyway, I've built the circuit shown and it works fine with the D850. MJKZZ Peter's solution is a good one where he uses a simple CPU to create the delay for the flash/strobe, he has a controller which has this built in now.

http://www.mjkzz.com/product-page/stand-alone-controller-with-remote

Best,
_________________
Research is like a treasure hunt, you don't know where to look or what you'll find!
~Mike
Back to top
View user's profile Send private message
TheLostVertex



Joined: 22 Sep 2011
Posts: 295
Location: Florida

PostPosted: Mon May 07, 2018 5:12 pm    Post subject: Re: Manual flash directly from LiveView with EOS 500D Reply with quote

mawyatt wrote:

This might be what's happening, but it seems the camera CPU should be on an interrupt driven trigger rather than in a long slow software checking loop.


As I recall, only live view behaves this way, while the triggering for a "normal" shutter has a much more predictable timing window. So it wouldnt surprise me if the normal shutter works on a interrupt, while LV has some software loop that detects the button press before sending the signal off to trigger the exposure.

As for the delay box, that is certainly a solution, but Ichthyophthirius's solution allows the shutter speed to be much short than if you had to have a large delay window waiting for the camera to be triggered at some random interval.
_________________
-Steven
Flickr Macro Rig Control Software
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.photomacrography.net Forum Index -> Macro and Micro Technique and Technical Discussions All times are GMT - 7 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group